Keeping remote directory up to date - Existing files only

Advertisement

ino
ino avatar
Joined:
Posts:
3
Location:
Brno

Keeping remote directory up to date - Existing files only

Hi,

I am using Keeping remote directory up to date Ctrl+U functionality to upload only changed files to remote directory.
My settings of Synchronization options is as follow:"Existing files only" is checked and the rest of check-boxes are unchecked.

In previous full version 4.1.9 it works as I needed. When edited file on local machine was saved, WinSCP find that file and uploaded it to the remote directory.
But in current full version 4.2.5 it is trying to upload probably all files in the directory (I did not tried what files it wants upload because I must not overwrite other files than the only one I am editing...)

Hope I describe it understandable ;-)

I guess it is a bug, isn't it? I tried to search forum but nothing similar to this topic was found.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: Keeping remote directory up to date - Existing files only

Can you try to downgrade to 4.1.9 and try it again with the very same settings to make sure the upgrade was actual reason for the problem?
_________________
Martin Prikryl

Reply with quote

ino
ino avatar
Joined:
Posts:
3
Location:
Brno

Re: Keeping remote directory up to date - Existing files only

martin wrote:

Can you try to downgrade to 4.1.9 and try it again with the very same settings to make sure the upgrade was actual reason for the problem?

Yes I did it before submitting my first post.

Now I tried to run both version at the same time (I just copy WinSCP folder to different location, unistalled it and install the other version. After that I run both version with default setting. During uninstallation I confirmed the Clean up to remove all configuration).

The results are same as described in the first post. Only one thing which I did not mentioned is that WinSCP shows me Error dialogue "Cannot overwrite remote file ...." "Permission denied". (this error is correct because I do not have permission to edit that first file in selected directory. Luckily because of that error message I found out, that WinSCP is trying to modify more files than I requested by modification of only one file which should be uploaded).

So to your question - yes I am sure that on my PC it behaves as I described.
WinXP SP2 Eng,
WinSCP 4.1.9 vs WinSCP 4.2.5

Keep remote directory up to date
Directories
Watch for changes in the local directory: (local dir)
... and automatically reflect them on the remote directory: (remote dir)
Synchronize options
[ ] Delete files
[X] Existing files only
[ ] Update s ubdirectories
[ ] Selected files only
[ ] Use same options next time
[ ] Synchronize on start
[Default] Transfer settings...

Reply with quote

Advertisement

You can post new topics in this forum