Overwrite prompt not always appearing

Advertisement

Greg
Joined:
Posts:
11

Overwrite prompt not always appearing

I think I've found a bug in version 4.2.5 build 624:

In the explorer interface, if you drag a file from the local PC to the folder displayed on the remote side, you'll get an overwrite confirmation request if that file already exists ("Remote file <whatever> already exists. Overwrite?").

However, if you drag a file to a folder that is not displayed (e.g. by dragging it either to one of the folders on the left hand side, or to a sub-folder displayed in the open folder on the right hand side), no such prompt is presented and the file is silently overwritten if it already exists.

I hope that's clear, but feel free to ask if you need clarification,

Greg

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Overwrite prompt not always appearing

What protocol?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

With SCP it indeed does not work. That's limitation of the protocol.
_________________
Martin Prikryl

Reply with quote

Greg
Joined:
Posts:
11

Yet it does work if the file is dropped in to a folder that is open.

Presumably it's WinSCP checking the contents of the (open) folder, could it not simply check the contents of the destination folder regardless if it's open or not?

Greg

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

It could, but I do not plan to invest the time into obsolete SCP protocol.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum