Login granted via GUI; rejected via automation/scripting

Advertisement

PeteLachall
Guest

Login granted via GUI; rejected via automation/scripting

I'm using the command below to connect & download files. It works for many accounts (same server). It does not work for one account. I am able to connect/download files via the WinSCP GUI for the problem account.

Note: the account that is not working is the only one whose password contains a + symbol.

The command is:

winscp.exe /log=logs/winscpDownloadLog.xml /command "option batch on" "option confirm off" "open -hostkey=""(hostkey)"" (username):(password)@(hostname)" "get *.txt importFiles\" "exit"

The command issues a return value of 1. There is no useful info in the XML log, but if I use non-XML logging, the last lines are as follows:

. 2010-02-23 15:52:33.132 Prompt (6, SSH password, , &Password: )
. 2010-02-23 15:52:33.147 Using stored password.
. 2010-02-23 15:52:33.147 Sent password
! 2010-02-23 15:52:36.210 Access denied
. 2010-02-23 15:52:36.210 Access denied
. 2010-02-23 15:52:36.210 Prompt (6, SSH password, , &Password: )
. 2010-02-23 15:52:36.225 Disconnected: Unable to authenticate

Once again, the username/password is accepted when I use the WinSCP GUI.

I've tested on WinSCP versions 4.2.4 & 4.2.6
I'm running Windows XP Pro SP3

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,032
Location:
Prague, Czechia

Re: Login granted via GUI; rejected via automation/scripting

Please read FAQ. If that does not help, come back.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum