10-second delay of the first remote operation after idling

Advertisement

dandvd
Joined:
Posts:
15
Location:
Silicon Valley

10-second delay of the first remote operation after idling

I couldn't find much about this in the documentation or the forum, but it does seem like an FAQ, so feel free to point me in the right direction:

If I don't do anything with WinSCP for several minutes (under 6), then I attempt to do something on the remote host, for example edit a remote file, or change directory to one that hasn't been cached, WinSCP will freeze for 10+ seconds before performing the operation. This only happens for some hosts. It happens on a RHEL AS release 4 (Nahant Update 3), but not on Ubuntu 8.10.

How can I fix this? It's becoming more and more annoying.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,599
Location:
Prague, Czechia

Re: 10-second delay of the first remote operation after idling

It is possible that the remote process handling your connection was suspended due to inactivity and it takes a time before it is resumed.
_________________
Martin Prikryl

Reply with quote

dandvd
Joined:
Posts:
15
Location:
Silicon Valley

Re: 10-second delay of the first remote operation after idling

martin wrote:

It is possible that the remote process handling your connection was suspended due to inactivity and it takes a time before it is resumed.

Any idea how I can test if that is the case (or maybe even fix it?)

I connect to the same host with an SSH client (ZOC), and I don't experience this delay. ZOC does have an anti-idling feature, but it's set for 3600 seconds.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,599
Location:
Prague, Czechia

Re: 10-second delay of the first remote operation after idling

OK, so may, can you post a log file, showing the problem? Maybe it records some useful information. Possibly key re-exchange or something.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum