Topic "winscp doesn't work with proftpd/mod_sftp"

Author Message
bman

Guest


Hi,

I am using proftpd 1.3.3 final with configured mod_sftp (proftpd handles SFTP).

And I am unable to copy files to a server, but I can delete existing files from a server.

When I want to copy file, WinSCP shows this message:

Code:

--
No such file or directory.
Error code: 2
Error message from server (en-US): No such file
Request code: 3
--


proftpd log shows this:

[code]
--
[code]Feb 26 11:01:06 mod_sftp/0.9.7[10351]: using '/etc/ssh/ssh_host_rsa_key' as RSA hostkey
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: using '/etc/ssh/ssh_host_dsa_key' as DSA hostkey
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: received client version 'SSH-2.0-WinSCP_release_4.0.6'
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: handling connection from SSH2 client 'WinSCP_release_4.0.6'
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session key exchange: diffie-hellman-group-exchange-sha1
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session server hostkey: ssh-rsa
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session client-to-server encryption: aes256-cbc
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session server-to-client encryption: aes256-cbc
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session client-to-server MAC: hmac-sha1
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session server-to-client MAC: hmac-sha1
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session client-to-server compression: none
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: + Session server-to-client compression: none
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: sending acceptable userauth methods: publickey,keyboard-interactive,password
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: sending userauth banner
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: sending userauth banner
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: sending userauth success
Feb 26 11:01:06 mod_sftp/0.9.7[10351]: user 'bman' authenticated via 'keyboard-interactive' method
Feb 26 11:01:08 mod_sftp/0.9.7[10351]: 'subsystem' channel request for 'sftp' subsystem
Feb 26 11:01:08 mod_sftp/0.9.7[10351]: using SFTP protocol version 5 for this session (channel ID 0)
Feb 26 11:01:12 mod_sftp/0.9.7[10351]: error checking '/home/bman/Ax.mpx' for LSTAT: No such file or directory
Feb 26 11:01:12 mod_sftp/0.9.7[10351]: error checking '/home/bman/Ax.mpx.filepart' for LSTAT: No such file or directory
Feb 26 11:01:12 mod_sftp/0.9.7[10351]: client requested OPEN_EXISTING flag in OPEN command and '/home/bman/Ax.mpx.filepart' does not exist
Feb 26 11:01:12 mod_sftp/0.9.7[10351]: error checking '/home/bman/Ax.mpx.filepart' for LSTAT: No such file or directory
--
[/code]

I don't know if the problem is in the winscp or proftpd, but FileZilla in SFTP mode, console sftp work well.

I googled but find absolutely nothing about this problem.

Thank you
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
bman
[View user's profile]

Joined: 2010-03-01
Posts: 2
Location: Slovak Republic
I sent you email. Thanks.

prikryl wrote:
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
douglasj

Guest


I hate to say "me too", but... I am also having this problem.

I have just finished setting up our sftp server using proftpd 1.3.3 release with mod_sftp on Solaris 10.

I have started testing the windows sftp/scp clients that our uses will be likely to use. So far filezilla (sftp) and pscp (putty's scp client) have both passed, as have Sun's and Apple's implementation of OpenSSH.

When I tried winscp using sftp the first transfer to the server worked, but every test transfer afterwards either to or from has failed with the "No such file or directory" error. Copying back from the server to the client I get a "Permission denied" error. Another oddity is that I can't even log in to the server with WinSCP if I change it from sftp to scp.

So, after that long winded explanation, can I get in on the debugging too? Smile This is probably the only thing keeping us from rolling the server out to our users.

-doug
TRaNQuiL

Guest


Just try to add this to your proftpd config file:

SFTPClientMatch ".*WinSCP.*" sftpProtocolVersion 4
douglasj

Guest


Thank you TRaNQuiL, that appears to have solved my problem. Can you tell me why it does though?

Thanks again!

-doug


TRaNQuiL wrote:
Just try to add this to your proftpd config file:

SFTPClientMatch ".*WinSCP.*" sftpProtocolVersion 4
bman
[View user's profile]

Joined: 2010-03-01
Posts: 2
Location: Slovak Republic
Great. It works!

probably mod_sftp manual page, should have some explicit remark about
this issue with WinSCP...

TRaNQuiL wrote:
Just try to add this to your proftpd config file:

SFTPClientMatch ".*WinSCP.*" sftpProtocolVersion 4
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License