synchronize command doesn't with -delete option

Advertisement

eddzzz
Joined:
Posts:
3

synchronize command doesn't with -delete option

I would like to backup a directory to a server via the commandline. I got it working, but for some reason only without the delete option, which I really need.

What works is:
A: winscp.exe nbbackup /command "synchronize remote d:\nbbackup /nbbackup"

What does not work is:
B: winscp.exe nbbackup /command "synchronize remote d:\nbbackup /nbbackup -delete -mirror"

The second command doesn't work at all. It not only doesn't delete, but it also doesn't copy any files anymore.
What am I doeing wrong?

Thanks.

Last edited by eddzzz on 2010-03-12 09:05; edited 1 time in total

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,502
Location:
Prague, Czechia

Re: synchronize command doesn't with -delete option

So what does it do? What's the output on the console?
_________________
Martin Prikryl

Reply with quote

eddzzz
Joined:
Posts:
3

There is no output to the screen when I enter command B, it just gives back a prompt.

Actually this is the same behaviour as when I enter command A, which also only gives back a promt. But then it does sync the two directories. Problem is that i need it to delete the removed files.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,502
Location:
Prague, Czechia

Run:
winscp.com nbbackup /command "synchronize remote d:\nbbackup /nbbackup -delete -mirror"
(note the .com extension)

Last edited by martin on 2010-12-25; edited 1 time in total

Reply with quote

Advertisement

You can post new topics in this forum