Topic "Parameters not working for encryption type"

Author Message
JimGriffith
[View user's profile]

Joined: 2009-02-19
Posts: 21
I'm trying to setup a script that specifies an explicit connection using port 21. If I use ftps in the session it tries to connect over 990. If I use ftp it tries to connect with no encryption. I've tried putting the parameters in multiple places with the same results.

script:

open ftps:user:pass@ftps.siteaddress.com /passive /explicitssl
option confirm off
option transfer binary
exit

Results: connects to 990 using implicit encryption

script:

open ftp:user:pass@ftps.siteaddress.com /passive /explicitssl
option confirm off
option transfer binary
exit

results: connection via port 21 with no encryption

I've tried putting in the command line in different places as well

winscp.exe /script=c:\script.txt /passive /explicitssl /log=c:\log.txt

winscp.exe /passive /explicitssl /script=c:\script.txt /log=c:\log.txt

winscp.exe /script=c:\script.txt /log=c:\log.txt /passive /explicitssl

It appears to be ignoring the passive and encryption parameters and relying strictly on the protocol for it's connection method. Any suggestions? Thanks!
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Sorry, not having enough time to read this carefully. What is this different to the problem we have already solved?
_________________
Martin Prikryl
JimGriffith
[View user's profile]

Joined: 2009-02-19
Posts: 21
The previous issue was specifying a port number. This issue is using the /explicitssl and /explicittls parameters. It's not recognizing these.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License