Disable keyboard-interactive after key refusal

Advertisement

Guest
Guest

Disable keyboard-interactive after key refusal

Hi,

I'm running a certificate authenticated SFTP script using "option batch abort" every 15 minutes. Approx every two weeks I get "Server refused our key" - I assume it's about a network problem and the key isn't transfered correctly to the server. Anyway, I can't do anything about that.

What's bugging me is that after the has been refused the script switches to keyboard-interactive authentication and stalls.

I tried serveral options in the Authetication tab in WinSCP.exe, none of them worked.

Is there a way to abort the login process at all when the key is refused?

Regards

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Disable keyboard-interactive after key refusal

The prompt should cancel itself in 10 secs. Doesn't it? What version of WinSCP are you using?
_________________
Martin Prikryl

Reply with quote

Guest
Guest

Re: Disable keyboard-interactive after key refusal

martin wrote:

The prompt should cancel itself in 10 secs. Doesn't it? What version of WinSCP are you using?

Hi,

thanks for your answer, unfortunately it doesn't cancel itself, it stalles for hours.

I'm using WinSCP 4.2.7 (Build 758). I use WinSCP.com and don't use the /console switch of the .exe

Here's a part of log:
. 2010-07-21 07:00:01.430 Initialised AES-256 CBC server->client encryption
. 2010-07-21 07:00:01.430 Initialised HMAC-SHA1 server->client MAC algorithm
. 2010-07-21 07:00:01.648 Reading private key file "C:\SomeDummyDir\Dummy.ppk"
! 2010-07-21 07:00:01.648 Using username "Dummy".
. 2010-07-21 07:00:01.695 Offered public key
! 2010-07-21 07:00:01.758 Server refused our key
. 2010-07-21 07:00:01.758 Server refused public key
. 2010-07-21 07:00:01.820 Prompt (5, SSH server authentication, Using keyboard-interactive authentication., Password: )


I start Winscp.com out of the script with this command:
winscp.com /log=%SFTPLog% /command "option batch abort" "option transfer ascii" "open %SFTPUser%@%SFTPHost%" "get *.*" bye


Regards

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Disable keyboard-interactive after key refusal

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

HoloMan
Joined:
Posts:
2
Location:
Munich, Germany

Mail sent

Hello prikryl,

I've registered in the forum and sent you an email.

Thanks for you help.

Reply with quote

HoloMan
Joined:
Posts:
2
Location:
Munich, Germany

Debug sent

Hello,

I've reproduced the problem and sent the debug output.

Thanks for your support

Regards

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Disable keyboard-interactive after key refusal

This bug has been added to tracker.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum