Topic "*Invalid Access to Memory* --after 'close' command in script"

Author Message
[View user's profile]

Joined: 2010-07-26
Posts: 2
Using the current version of WinSCP [4.2.8] on Windows XP SP 3.
Running a script to synchronize local to remote. Actual synchronization is performed flawlessy.
After 'close' command I recieve 'Invalid Access to Memory", returns an error level of 1.
This happens every time - always reproducible. Also reproduced on a different PC.

// I invoke script with this command:
"C:\Program Files\WinSCP\" /log"C:\DATA_Archive\Data Synchronize.xml" /script="C:\Program Files\Fallbrook Technologies\WinSCP Sync.txt" /parameter "C:\DATA" "Test Data/xxxxxxxx/EOL"

// This is the script "WinSCP Sync.txt":
option echo off
option batch on
option confirm on
option reconnecttime 10

# open [ sftp|ftp|scp:// ][ <user> [ :password ] @ ] <host> [ :<port> ]
open s -hostkey="ssh-rsa 2048 nn:nn:nn:nn:nn:nn:nn:nn:nn:nn:nn:nn:nn:nn:nn:nn"

# lcd "%1%"
# cd "%2%"

# SYNCH copies new local to remote
# synchronize local|remote|both [ <local directory> [ <remote directory> ] ]
synchronize remote "%1%" "%2%"



// I get the following output
// In this case everything is synched already from previous calls.
// Get same error when there are files to synch also
echo off
batch on
confirm on
reconnecttime 10
Searching for host...
Connecting to host...
Using username "xxxxxxx".
Authenticating with pre-entered password.
Starting the session...
Reading remote directory...
Session started.
Active session: [1] xxxxxxx@xxxxxxx/
Local 'C:\DATA' => Remote 'Test Data/Tristar/EOL'
Nothing to synchronize./
Now session
Invalid access to memory

After this, I exit, and read the errorlevel 1.

I have successfully performed a very similar operation in the past, perhaps about 3 months ago. However, it was on a different machine with a different version of the script. I apologize for not knowing much more than that - I uninstalled after testing and only returned to it these last 2 weeks.

Thank you and best regards, Newton
[View user's profile]

Joined: 2010-07-26
Posts: 2
I just verified that the above command and script works in 4.2.7.

I also tried both "" and "WinSCP.exe /console", and there is no difference in behaviour: it works in 4.2.7, does not work in 4.2.8.

I have to revert back to 4.2.7 to get the job done, but looking forward to a patch/update. If you need any additional info please ask - I will try to get it for you.

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License