Invalid access to memory - when use scripting

Advertisement

joujoujou
Guest

Invalid access to memory - when use scripting

Hi again.

Already asked for help with scripting, got the answer, but unfortunately not solved totally.

WinSCP 4.2.8 (same problem when used 4.2.7), XP professional SP3 (EN).

My previous thread - https://winscp.net/forum/viewtopic.php?t=8815

Currently used command (batch file):

@ECHO OFF
@ECHO Odpalamy FTP... :-)
@PING 1.1.1.1 -n 1 -w 10000 >NUL
@START C:"\Documents and Settings\joujoujou\Desktop\Pulpitt\winscp\WinSCP.exe" /console /script=C:"\Documents and Settings\joujoujou\Desktop\Pulpitt\winscp\test.txt"    

Script:
option batch on

option confirm off

option reconnecttime 1

open user@domain.com

synchronize remote

keepuptodate C:"\Program Files\Cumulus\web" /var/www/domain.com/htdocs/weather    

Note: user and domain details changed to keep some privacy. ;)

<invalid hyperlink removed by admin>

Problem exists only when use scripts - in GUI mode all is working O.K.

I'd rather prefer not to publish log I've saved.

Would be glad to email it, or somehow like that.

Thank you.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Invalid access to memory - when use scripting

Thanks for your post. This bug is being tracked already.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Thank. Though the bug is fixed already.
_________________
Martin Prikryl

Reply with quote

serendipity
Joined:
Posts:
1
Location:
France

Re: Invalid access to memory - when use scripting

Hi, i'm facing the same problem. Happy to know it's fixed, but when 4.2.9 will be released?
Thanks.


joujoujou wrote:

Hi again.

Already asked for help with scripting, got the answer, but unfortunately not solved totally.

WinSCP 4.2.8 (same problem when used 4.2.7), XP professional SP3 (EN).

My previous thread - https://winscp.net/forum/viewtopic.php?t=8815

Currently used command (batch file):

@ECHO OFF
@ECHO Odpalamy FTP... :-)
@PING 1.1.1.1 -n 1 -w 10000 >NUL
@START C:"\Documents and Settings\joujoujou\Desktop\Pulpitt\winscp\WinSCP.exe" /console /script=C:"\Documents and Settings\joujoujou\Desktop\Pulpitt\winscp\test.txt"    

Script:
option batch on

option confirm off

option reconnecttime 1

open user@domain.com

synchronize remote

keepuptodate C:"\Program Files\Cumulus\web" /var/www/domain.com/htdocs/weather    

Note: user and domain details changed to keep some privacy. ;)

<invalid hyperlink removed by admin>

Problem exists only when use scripts - in GUI mode all is working O.K.

I'd rather prefer not to publish log I've saved.

Would be glad to email it, or somehow like that.

Thank you.

Reply with quote

peterj
Joined:
Posts:
1
Location:
Melbourne, Australia

Re: Invalid access to memory - when use scripting

serendipity wrote:

Hi, i'm facing the same problem. Happy to know it's fixed, but when 4.2.9 will be released?
Thanks.


I too am suffering from this problem, although it appears to be both in the interactive command line mode and running a script. Can you advise when the next release will be ou as this is affecting a production system now.

Regards,

P

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Invalid access to memory - when use scripting

In few weeks.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

joujoujou wrote:

Exactly the same when running winscp 4.29.
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum