WinSCP Permissions Error

Advertisement

sluice
Joined:
Posts:
9

WinSCP Permissions Error

I'm using WinSCP 4.2.9 to sftp files from my Windows 7 workstation to a Win 2008R2 server running Sysax sftp server service. I want to script the process so I have set up a session named Purple from the GUI to synchronize from my workstation to the remote server using sftp v5. I have unchecked the permissions and Preserve timestamp boxes in Preferences/Transfer. When I give winscp.com the command to synchronize remote, it copies the next new file in the local folder and then stops with the following error. Filezilla is the next new file in the list:

FileZilla_3.3.4.1_win32-s | 4100 KiB | 1651.1 KiB/s | binary | 100%
Upload of file 'FileZilla_3.3.4.1_win32-setup.exe' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn on 'Ignore permission errors' option.
The server does not support the operation.
Error code: 8
Error message from server:
Request code: 9
(A)bort, (R)etry, (S)kip, Ski(p) all: Abort

What am I doing wrong?

Reply with quote

sluice
Joined:
Posts:
9

WinSCP Permissions Error

I should also say that I have tried:
synchronize remote -nopreservetime -nopermissions

but that results in the same activity - i.e. 1 file is copied and the error previously described comes up.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,268
Location:
Prague, Czechia

Re: WinSCP Permissions Error

For synchronization, preserving the timestamp is implicit, it cannot be turned off. Otherwise synchronization cannot work (the next time).
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum