Can't list a directory (tried passive and active modes)

Advertisement

kaizersose
Joined:
Posts:
1

Can't list a directory (tried passive and active modes)

I have a problem to list a directory of my Apache FTP server, while all other ftp client have no problem (filezila, flashFxp, command line FTP, Total Commander, etc.)
Here is the log:
--------------------------------------------------------------------------
Using FTP protocol.
Doing startup conversation with host.
PWD
257 "\" is current directory.
Getting current directory name.
Retrieving directory listing...
TYPE A
200 Command TYPE okay.
PASV
227 Entering Passive Mode (127,0,0,1,232,57)
LIST -a
150 File status okay; about to open data connection.
226 Closing data connection.
Directory listing successful
Startup conversation with host finished.
Changing directory to "DEFAULT".
Synchronizing current directory "\".
CWD \
250 Directory changed to \
CWD DEFAULT
250 Directory changed to \DEFAULT
Getting current directory name.
PWD
257 "\DEFAULT" is current directory.
Retrieving directory listing...
CWD /DEFAULT/DEFAULT/
550 No such directory.
Could not retrieve directory listing
(ECommand) Error listing directory '\DEFAULT'.
Could not retrieve directory listing
No such directory.
TYPE I
200 Command TYPE okay.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.


as you can see, somehow, it asks for CWD of incorrect path, therefore getting an error. Can you think of any reason for him to do that?

Regards,
Oleg.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,268
Location:
Prague, Czechia

Re: Can't list a directory (tried passive and active modes)

WinSCP can work only against server with Unix-like paths.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum