Invalid Access to memory error: 4.3 beta

Advertisement

a7ndrew
Guest

Invalid Access to memory error: 4.3 beta

Hi, Just to let you know I am getting an "Invalid access to memory" error in 4.3 beta, when pressing connect to server. I am running Win 7 Professional, 64 bit. I dropped back to 4.29 which works fine.

Reply with quote

Advertisement

Cecco
Joined:
Posts:
4

Re: Invalid Access to memory error: 4.3 beta

a7ndrew wrote:

Hi, Just to let you know I am getting an "Invalid access to memory" error in 4.3 beta, when pressing connect to server. I am running Win 7 Professional, 64 bit. I dropped back to 4.29 which works fine.

Same your problem with 4.3 beta.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Invalid Access to memory error: 4.3 beta

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

Sacrejaune
Guest

Re: Invalid Access to memory error: 4.3 beta

I have the same problem with the 4.3 beta. It doesn't matter where I try to connect I always get "Invalid access to memory" error message right after pressing Login.
My OS is Windows XP Home with Service Pack 3.

Reply with quote

AJC
Guest

On a fully patched (to end of life) Windows 2000 Pro box 4.3 Beta produces the same "Invalid access to memory" as other report. This was an "update" from 4.2.6 Build 721.

Reply with quote

pb
Guest

I'm getting the same error with 4.3. Existing connections in winscp.ini work fine, but I can't create any new connections or edit existing connections. I've tried running as administrator and a regular user -- both produce the error.

Reply with quote

Guest

AJC wrote:

On a fully patched (to end of life) Windows 2000 Pro box 4.3 Beta produces the same "Invalid access to memory" as other report. This was an "update" from 4.2.6 Build 721.

I neglected to add that 4.2.9 Build 938 works perfectly on 2000 Pro.

Reply with quote

AJC
Guest

On Windows XP-Pro (32 bit) 4.3.Beta (Build 1029) fails "EPrivilege" attempting to connect. Reverting to 4.2.9 (938) its ok.

Reply with quote

t33r0y
Guest

Invalid Access to Memory

Same error here on Windows 7 64-bit Enterprise edition running WinSCP 4.3.0 (Build 1029). This appears to only happen when connecting to a site using the 'New' button and manually entering in connection information. My saved sessions appear to be working just fine.

Reply with quote

Rakushun
Joined:
Posts:
8

Same for me. Win 7, 64 bit, Version 4.3.0 beta (Debug+Release Version), Build 1029.

If I click on a saved session and hit the "Login" button, WinSCP connects smoothly. If I click on a saved session, hit the "Edit" button, change the username and hit the "Login" button (without saving the session), either WinSCP crashes completely or there is an "Invalid access to memory" message box.

I have a debug log at hand if desired.

Reply with quote

rojaro
Joined:
Posts:
1

Win XP SP3, 32 bit, Version 4.3.0, Build 1029.

I get the "EPrivilege" error message when i try to use FTP. Using tcpdump to monitor the FTP server, i also noticed that it doesnt receive a connection at all, so it looks to me that the problem occurs before WinSCP actually tries to open the connection.

However, SFTP/SCP work without problems :)

Reply with quote

Aguest2
Guest

same problem

Installed WinSCP 4.3 (build 1029) on WinXP Professional SP3, same error "Invalid access to memory"

One user mentioned the workaround of using a saved session. Confirmed, created a new saved session allowed me to connect.

Ps: having the registry update included is really annoying. I had a user install it despite me asking her to unclick it, and she had to reboot. It should NOT be the default option!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Invalid Access to memory error: 4.3 beta

Thanks for your posts. This bug has been added to tracker.
_________________
Martin Prikryl

Reply with quote

ckg
Guest

Re: same problem

Win7 64 bit, same error "Invalid access to memory". Also confirmed that you can save the session then open that saved session.

Aguest2 wrote:

Installed WinSCP 4.3 (build 1029) on WinXP Professional SP3, same error "Invalid access to memory"

One user mentioned the workaround of using a saved session. Confirmed, created a new saved session allowed me to connect.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

JY_N wrote:

I'm having the same problem too. Windows 7, 32-bit. Is there any way to fix this?
You can downgrade to 4.2.9. Anyway 4.3.1 with a fix will be released within a week.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: same problem!

invalid access to memory wrote:

win vista, 32bit,
worked well with 4.2.9 version,too.
Have you tried the latest version? 4.3.2.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum