Topic "I keep getting a "No differences found" dialog box"

Author Message
Costello

Guest


I have had this weird problem twice.
The first time I had it, I had to reinstall WinSCP completely.
It's happening again. I'm using the latest version (checked it with the app's 'check for updates' feature).

My setup:
1) I am using the commander interface
2) Using a regular SSH/SFTP session
3) Latest version of WinSCP.

It always worked fine. But suddenly, for no apparent reason, things started to go wrong.
1) Whenever I enter a (remote) directory, WinSCP selects all the files in the directory automatically.
2) When I enter an empty directory, I get a dialog box saying "No differences found" (thats from the Compare Directories feature apparently)
3) when I draw a selection with the mouse (in an empty folder) I get the same dialog box
4) When I use any feature of the program, WinSCP clears my selection in the remote panel and selects all the files. Or if the directory is empty, it says "no differences found".

It looks as though the Compare Directories function is locked and I cannot disable it.
Worse part is, when I restart WinSCP, it still does that!

I have been looking for similar issues on google, in the FAQ, the forums, but I couldn't find anything so I decided to post here.

Is there any way to unlock the "Compare directories" function?

Thanks for your help!
Costello
Advertisements
Costello

Guest


this could be a serious bug. Or maybe a bug that isn't caused by WinSCP, I don't know.

I know that the WinSCP configuration is stored here: (I'm in registry mode)
HKEY_CURRENT_USER\Software\Martin Prikryl\WinSCP 2\Configuration

I've removed the whole key, restarted WinSCP, and I still get the bug!

Also, I get the bug for all of my sessions.

Help Neutral
Guest




I think I begin to understand the issue.
It doesnt seem related to WinSCP but to my computer!
I've noticed strange behavior in applications.

When I do specific things with my mouse cursor (drag/drop) it seems as though the Ctrl+C key combination was sent to the OS.

Ctrl+C is the shortcut for "directory compare" in WinSCP.
I've noticed bugs in other applications so I think thats where it comes from.

Now to debug my computer...
Costello

Guest


Alright so much for a buggy application.

I found out which process was causing all the CTRL+C's

It was some chinese translation software
<invalid hyperlink removed by admin>
MDBG Chinese Reader

I killed that app and the bugs stopped.

Sorry for the trouble! Issue solved.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Thanks for sharing the solution.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License