WinSCP Windows 7 Installation as a limited user fails

Advertisement

Neil (SM)
Guest

WinSCP Windows 7 Installation as a limited user fails

Hello:

Using version 4.31, exe installation file.

When trying to install under Windows 7 (I'm using 64-bit) as a limited user, the installation fails with an Unable to Create Directory error message. The solution is to right-click and use "Run as Administrator" for the installation file, and follow the UAC prompts to elevate.

I think the expected behavior here would be for the installer to automatically attempt to elevate and produce a UAC prompt without requiring to manually run as an admin.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: WinSCP Windows 7 Installation as a limited user fails

Thanks for your post. This issue has been added to tracker.
_________________
Martin Prikryl

Reply with quote

Ricardo
Donor
Ricardo avatar
Joined:
Posts:
107

Martin just needs to set the value of "PrivilegesRequired" to "admin" instead of "none" in winscpsetup.iss, or, instead, simply remove that line, because the default value is "admin".
However, limited users won't install.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Ricardo wrote:

However, limited users won't install.
That's exactly the reason I have none there. Because WinSCP does not need admin privileges to install. Of course as long as you change the installation directory.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: WinSCP Windows 7 Installation as a limited user fails

I'm just not able to find a use case in which this happens. Windows always detects need to run the installer as admin for me. Can you tell me what are the circumstances that prevents Windows from detecting that in your case?

Reply with quote

Advertisement

You can post new topics in this forum