Topic "Problem using the command OPEN with username and password"

Author Message
[View user's profile]

Joined: 2011-02-01
Posts: 2
I will like to create a script to synchronize folders contents. I already read the instructions and have the commands needed. I tried first doing it manually and got a problem with the open command using an username and password. The host doesn't have a FQDN so I have to use the IP address instead.

If I do it command by command I have no problem:

winscp> open ftp://XXX.XXX.XXX.XXX
Prompting for credentials...
Username: XXXXXXX
Password: XXXXXXX (actually it looks blank)
Connecting to XXX.XXX.XXX.XXX ...
Connected with XXX.XXX.XXX.XXX. Waiting for welcome message...
Starting the session...
Reading remote directory...
Session started.
Active session: [1] XXX.XXX.XXX.XXX

Notice that I have to use "open ftp://" if I use the command with the IP address alone it doesn't work.

Then I tried:

winscp> open XXXXXX:XXXXXX@ftp://XXX.XXX.XXX.XXX

but it returns:

winscp> open XXXXXX:XXXXXX@ftp://XXX.XXX.XXX.XXX
Searching for host
Host does not exist

Can you please tell me what I'm doing wrong?

[View user's profile]

Joined: 2011-02-01
Posts: 2
Never mind found the cause of the problem. I have to use:

OPEN ftp://username:password@IPADDRESS

It is now working.


You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License