Internal Error fz#list in 4.3.2 with FTP/TLS Explicit

Advertisement

daymobrew
Donor
Joined:
Posts:
8
Location:
Dublin, Ireland

Internal Error fz#list in 4.3.2 with FTP/TLS Explicit

<invalid link removed>

Using WinSCP 4.3.2 GUI on Vista SP2
Server: ProFTPD 1.3.2e Server (ProFTPD)
I connect to my host's FTP server with TLS Explicit encryption (SCP not supported).

The connection drops frequently. It has been since I changed from plain FTP to use TLS. Since 4.3.2 upgrade I am seeing some Internal error and then the app hangs.
The Internal error is preceded by a Invalid Response to PWD command 'Protection set to Private'

Debug 2 log at: <invalid link removed>
I connected, within 40 sec there was a timeout and disconnect. After it reconnected it got the "Error getting name of current remote directory." error. I clicked OK and the app hung.

Reply with quote

daymobrew
Donor
Joined:
Posts:
8
Location:
Dublin, Ireland

Log from debug version emailed to Martin

Thank you for the debug version. It took a while for the app to crash (I haven't had a crash on the non-debug version today).

Attached is a compressed copy of the log where the crash occurred at the end. The log is 35MB, bzip compressed to 1.5MB.
You can see *lot* of internal errors at the end - I left the app for a minute or two before forcing it to close.
Lots of lines line:
[11:50:36.236] [01AC] [SessionInfo.cpp:658:TSessionLog::Add] [Internal error fz#disconnect (0080).]

Reply with quote

Advertisement

You can post new topics in this forum