Invalid access to memory

Advertisement

pflammertsma
Guest

Invalid access to memory

WinSCP 4.3.2 (Build 1201)
Problem has always occurred, in at least previous two versions
Protocol: FTP, No encryption, port 21
GUI: Yes (haven't tried scripting/automation), commander style
Server software: Microsoft IIS 7

Problem:

After several minutes of being idle, WinSCP pops up with the following error:

Invalid access to memory    

Behind that dialog is another dialog:

Invalid response to PWD command 'OPTS UTF8 command successful - UTF8 encoding now ON.
'.    

WinSCP subsequently tries to reconnect, but simply hangs on a white (empty) reconnection dialog.

If there's any further diagnostics that I can do for you, please let me know as I can reproduce this every time.

Reply with quote

Advertisement

pflammertsma
Guest

Disabling passive mode appears to cause WinSCP to hang without any error messages or reconnection dialog at all.

In either case (passive mode on/off), when the application hangs, the only thread showing any signs of life is cycling around the following function call:

WinSCP.exe!FilezillaintfFinalize+0x31f44    

Reply with quote

Guest

Correction on my previous post: I had disabled Keep-Alive, not passive mode. I am presently testing with both disabled.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

I have sent you an email.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum