Invalid Port Number error occurs while open session in putty

Advertisement

skysaint
Joined:
Posts:
4
Location:
XinJiang, China

Invalid Port Number error occurs while open session in putty

Hi,

In case of using customized SSH port (e.g. 12712 instead of 22), and login name includes dash (e.g. "tssiprod-g"), WinSCP is able to login successfully, but when I try to open session in putty(Ctrl+P), putty error occurs: "Invalid Port Number".

I have tested the same scenario with putty separately, putty can login without errors, hence the bug should be the one of WinSCP, please check it. Thanks.

WinSCP version: Any
putty version: 0.60 (latest)
SSH server: OpenSSH_4.3p2
Host: CentOS release 5.6 (Final) Linux version 2.6.18-238.9.1.el5
Windows: WinXP SP3

Thanks in advance!

-Jansen

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Invalid Port Number error occurs while open session in putty

I cannot reproduce the problem. I have used the same port number, the same username, the same PuTTY version.

After you reproduce the problem, run PuTTY again and try to open stored session "WinSCP temporary session". What does it do?

Reply with quote

skysaint
Joined:
Posts:
4
Location:
XinJiang, China

Re: Invalid Port Number error occurs while open session in putty

Re-open "WinSCP temporary session", no problems, putty's just there waiting for password input.

My server has used the default port 22, and WinSCP has stored it with user "tssiprod". After I changed the port, and create a new user "tssiprod-g", the error appears.

Would the WinSCP config or other files be useful for trace the problem?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Invalid Port Number error occurs while open session in putty

Do you have a password stored in the WinSCP? Do you have password passing to PuTTY enabled? If you do, can you try to disable and see if it helps?

Also try to run PuTTY from command line password following string as an argument:
-load "WinSCP temporary session"

Reply with quote

skysaint
Joined:
Posts:
4
Location:
XinJiang, China

Re: Invalid Port Number error occurs while open session in putty

Disable password passing to putty, "Invalid port number" disappears.
My password is complicated thus I hope this problem could be resolved.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Invalid Port Number error occurs while open session in putty

Though I wasn't able to reproduce this exact problem, I can imagine that certain combination of quotes, colons and spaces in password can cause this. I'll see if I can fix this.
_________________
Martin Prikryl

Reply with quote

skysaint
Joined:
Posts:
4
Location:
XinJiang, China

Re: Invalid Port Number error occurs while open session in putty

FYI, the password is "8w}m<r-}RaN9z0.p+&+

Thanks!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Invalid Port Number error occurs while open session in putty

This issue has been added to tracker.

Reply with quote

Advertisement

You can post new topics in this forum