Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Boy do I feel dumb.

When I posted the .bat file, I saw it was logging to a location that didn't exist.

I fixed it. It seems to be working now.

Sorry about that. I have no idea how I didn't notice that before.

BAT/Script not working while CL does

Hi All -

So, every day, I move a file from my network to my client's bank. I've recently upgraded my server and move my scripts over to the new server. This WAS working on the old server.

Set up is this:
Task Scheduler executes a .bat file which runs a WinSCP script.

WinSCP Script is as follows:
open sftp://wokluprd:[password]@[bank address]
cd /incoming/c21opipd
lcd "\\remit\RFE-x9"
put * -nopermissions -nopreservetime

.Bat file text which executes this follows:
# start 
@echo off /script="BOATransfer-RFE.txt" /log="C:\Logs\WK\WK_log.log"
# end

When I open a command line session with the bank, entering those commands one by one works perfectly. When I run the .bat file (even if I run it as an admin) it does not.

Any ideas? Anything I can do to troubleshoot? This is particularly frustrating because the only difference is literally the physical server. Everything else is the same.