Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks, the option batch continue solved the problem :)

Synchronize fails when a "Permission denied" occurs on subfolder

WinSCP 1.17.10 (Build 11087) on Windows Server 2016

I use WinSCP in a commandfile with the following command line: /log="UK_Download.log" /script="UK_Download.scp"
Content of UK_Download.scp:
open sftp://novagraf:***
option batch off
lcd O:\UK_Mirror\UK_Data\Increment
cd /licensee/Increment
synchronize local -criteria=size -transfer=automatic -preservetime -filemask=|2017\

On the remote site there are several subfolder, but some of them don't have "read" permission,
This results in an abort of the cmd file, instead of skipping the subfolders that cannot be accessed. Therefore, it is not possible to do a local synchronize