Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Transfer Files

Good afternoon everybody. Hoping you can help me with the following question.
How can I indicate the transfer rate in my script?
This is my script
open sftp://user:clave@ -hostkey="xxxxxxx" 
PUT "D:\CecoDomi\Encrip\EcriC30E.FIR" /tef.001/entrada/E01012A2.A302001 

If I leave it as is this is the result:
Using configured transfer settings different from factory defaults.

D:\CecoDomi\Encrip\EcriC30E.fir |        1128 KB |   38.8 KB/s | binary |  16%
Host is not communicating for more than 15 seconds.
Still waiting...
Note: If the problem repeats, try turning off 'Optimize connection buffer size'.
Warning: Aborting this operation will close connection!
(A)bort (60 s): Abort
D:\CecoDomi\Encrip\EcriC30E.fir |        1128 KB |    9.8 KB/s | binary |  16%
Terminated by user.
(A)bort, (R)econnect (5 s): Reconnect
Searching for host...
Connecting to host...
Using username "01012B".
Authenticating with pre-entered password.
Starting the session...
Session started.
D:\CecoDomi\Encrip\EcriC30E.fir |            0 B |    0.0 KB/s | binary |   0%
Cannot overwrite remote file '/tef.001/entrada/E01012A2.A302001.filepart'.
General failure (server should provide error description).
Error code: 4
Error message from server (en): Failure.
Common reasons for the Error code 4 are:
- Renaming a file to a name of already existing file.
- Creating a directory that already exists.
- Moving a remote file to a different filesystem (HDD).
- Uploading a file to a full filesystem (HDD).
- Exceeding a user disk quota.
(D)elete, (A)bort, (R)etry, (S)kip, Ski(p) all: Abort

If I do it through the front, I can move the transfer rate to 1024 and the file passes without problem. So I suppose there must be a parameter that is put on the command line so that it also uses a transfer rate of 1024.

I appreciate the attention, and I hope you can help me