Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Unfortunately I don't quite understand what you mean :-(

Processing via the task planner always worked 100% smoothly and reliably. I hadn't changed anything in the script or the task planner. From one day to the next, execution via the task planner simply stopped working. If I ran the script manually via Command, everything worked wonderfully.

Unfortunately, I don't understand why execution via the task planner stopped working from one day to the next?

Hi Martin,

sorry, misunderstanding on my part...

I have now rebuilt the script and directly specified the SFTP server including user name and password in the open command. Now the script works again via the task planner.

It's just inexplicable to me why this is/was like this from one day to the next?

Hi Martin,
sorry for asking, but do I have to include the command in the script?

My script currently looks like this:
option batch abort
option confirm off
open Shopware6
put "\\SERVER01\transfer$\folder\folder\*" *
synchronize remote "\\SERVER01\transfer$\folder\folder" / -mirror

If yes, where? Can you please show me an example?

Re: Task scheduling no longer works

Please attach a full session log file showing the problem. Both from the scheduled and the manual run.

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Task scheduling no longer works

Hello everyone,

I have been using WinSCP Portable on my Windows 2019 Server for years and run a script file every hour with the task scheduler. Suddenly, for reasons I can't explain, files are no longer being transferred from the source to the destination. The task scheduler says "The process was completed successfully". If I run the script from the command prompt, it works. The script does the following:
option confirm off
open XYZ
synchronize remote "\\SERVER01\transfer$\Shop" /public_html/ -mirror

Do you have an idea?