Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: error decoding utf-8 string

Dietrich wrote:

I followed this discussion and don't see the solution.???? What can I do. In the newest version I don't find the possibility to force utf-8.

It is still there:
https://winscp.net/eng/docs/ui_login_environment
Dietrich

error decoding utf-8 string

I followed this discussion and don't see the solution.???? What can I do. In the newest version I don't find the possibility to force utf-8.
martin

LaytXP wrote:

I would be glad to help you. But I can only try a workaround, as I can't give you a test-account.

Thanks. Can you please send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
LaytXP

I would be glad to help you. But I can only try a workaround, as I can't give you a test-account.
martin

Re: UTF-8 characters not showing up properly

Can anyone provide me a tests account on a server? Or at least help me with testing a possible workaround?
LaytXP

How did he solve it? I have the same problem. If I force UTF-8 I can't download the files from the server. The program returns the error message, that the file doesn't exist.
JoKalliauer

Re: error decoding utf-8 string

martin wrote:

JoKalliauer wrote:

I made them with WinSCP
Version 5.5.2 (Build 4130)
(I don't understand the Question.)

OK, that's a different problem then. I need to see a log showing how you upload the file. Ideally to an empty folder.


Thank's for helping, our admin solved the Problem. :-)
martin

Re: error decoding utf-8 string

JoKalliauer wrote:

I made them with WinSCP
Version 5.5.2 (Build 4130)
(I don't understand the Question.)

OK, that's a different problem then. I need to see a log showing how you upload the file. Ideally to an empty folder.
JoKalliauer

Re: error decoding utf-8 string

martin wrote:

Thanks. Can you please enable Debug 2-level logging?


I made this settings:


martin wrote:

Also, how was those files created?


I made them with WinSCP
Version 5.5.2 (Build 4130)
(I don't understand the Question.)
martin

Re: error decoding utf-8 string

Thanks. Can you please enable Debug 2-level logging?

Also, how was those files created?
JoKalliauer

Re: error decoding utf-8 string

martin wrote:

This is XML log. I need a session log.


I enabled the Session log in https://winscp.net/eng/docs/ui_pref_logging

The file should be atteached.
martin

Re: error decoding utf-8 string

This is XML log. I need a session log.
JoKalliauer

Re: error decoding utf-8 string

martin wrote:


Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.


Thank's for linking how to enable Logging. (I am a newbee in WinSCP, I don't know much about WinSCP.)
But I think the log won't help you, cause there is no message.
It just decodes the letters wrong. (Don't know how to write it right in English.)

best regards
Johannes
martin

Re: error decoding utf-8 string

JoKalliauer wrote:

I have the same Problem: with (Ä Ö Ü ä ö ü)
In WinSCP 5.5.2:
If i enable UTF-8: (� � � � � �)
If i disable UTF-8: (? ™ „ +– )

In WinSCP 4.3.2:
If i enable UTF-8: Error: error decoding utf-8 string
If i disable UTF-8: (? ™ „ +– )

Ps. (I have a german version, so I don't know the exact englisch errormessage)

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
JoKalliauer

error decoding utf-8 string

I have the same Problem: with (Ä Ö Ü ä ö ü)
In WinSCP 5.5.2:
If i enable UTF-8: (� � � � � �)
If i disable UTF-8: (? ™ „ +– )

In WinSCP 4.3.2:
If i enable UTF-8: Error: error decoding utf-8 string
If i disable UTF-8: (? ™ „ +– )

Ps. (I have a german version, so I don't know the exact englisch errormessage)
srynoname

martin

srynoname

I am on 5.1.0.2625, using SFTP, the german umlaut "" isn't displayed correctly. I guess winscp uses some external library for ssh / ftps, I'd like to note that when using putty to ssh into the machine, I have to change the encoding to UTF-8 for it to properly display the german "". Maybe it's the same problem here? Besides that, great software!
Guest

5.0.9 RC works fine.


Thanks
martin

Can you try the latest beta version? 5.0.9 beta.
eiji-gravion

My apologies, I forgot to mention that I'm using the latest version of WinSCP (4.3.9), and I've tried using FTP and FTPES for the protocol.


Thanks again.
eiji-gravion

UTF-8 characters not showing up properly

Hello,

I noticed a few UTF-8 characters that show up as a question mark (?), and a few that if in a folder name, display correctly, but don't allow you go access them.

Examples:

Folders with ⁄⁄ display correctly, but don't allow you to access them.
Folders/files with ♥ ✴ show up as a question mark, and don't allow you to access them.

I'm sure there are other examples, but these are the ones I've noticed so far.


Thanks