Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

While you have not posted a complete log, I'm pretty sure that WinSCP agreed SFTP version 4 or newer with the server.

Changes are there's a bug in an implementation of the higher SFTP version in the server.

Try to force common version 3 in WinSCP preferences.
Version 3 is what FileZilla uses (not supporting any newer version).

https://winscp.net/eng/docs/ui_login_sftp

And consider reporting the bug to the server vendor.
Guest

Please refer to attached file, confirmed haven't check the option to change permission but still fail.
martin

In WinSCP you also set permissions, not only timestamp. Both are set using the same request. So the server may be referring to the permissions.

Try to turn off the Set permissions option:
https://winscp.net/eng/docs/ui_transfer_custom
Guest

uploaded
martin

Re: Preserve Remote Timestamp not working

Please attach a full session log file showing the problem (using the latest version of WinSCP). And a verbose FileZilla log too.

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Guest

Preserve Remote Timestamp not working

I built a sftp server by using WS_FTP, i used file zilla as SFTP client, if I checked preserve timestamp option on file zilla, it is working fine. When I changed to use winscp, even if preserving timestamp option has been checked, the error message pop up.

Upload of file .. was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn off setting permissions or preserving timestamp. Alternatively you can turn on 'Ignore permission errors' option.
“The server does not support the operation”

I don't think that the SFTP server does not support preserving timestamp because of it works fine that if I use file zilla as SFTP client.