Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: having the same problem, what exactly was the fix, please

The file was open and WinSCP couldn't copy the file. I had to close the file before the copy.

having the same problem, what exactly was the fix, please

i get the same exact error - winscp copying to remote side failed

This seems to be working now.

I've just tried this again and it's now working. Let me test again on Monday just to be sure that there's actually a problem and update accordingly.

Re: Error transferring file Copying files to remote side failed

Please attach a full session log file showing the problem (using the latest version of WinSCP).

A log file from FileZilla for a comparison would be helpful too.

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Error transferring file Copying files to remote side failed

I'm automating an upload of our web site from our local build server to our Azure remote hosting. I'm using the following commands to do this.
option batch abort
option confirm off
option transfer binary
open ftp://myusername:mypassword@domain/site/wwwroot
cd /site/wwwroot
synchronize remote -delete "E:\buildfolder" /site/wwwroot

However I'm getting the following errors:
Error transferring file web.config.

Copying files to remote side failed.
Access is denied.

I have tried running my script from the build server command line and from the build itself and it fails for both. I can upload the files manually via FileZilla though. I would prefer to make this a build task rather than a manual one. Any ideas?