Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: i have tried but cant get filemask to work

That's not really easy with WinSCP file mask.
Something like this might work:
put -filemask="*/tp/*.txt; */tp/*.trg; */aa/*.txt; */aa/*.trg" *

i have tried but cant get filemask to work

I have a shared drive that I am using to upload files.
My source directory is \\fil\prod\fsroot and I am uploading to the root of my ftp server.
My requirement is that I need all the *.txt and * .trg file from any subdirectories that have that name tp or aa. SO I have written the following but the script runs and nothing happens :(
can you please help. I also have a requirement that the files should be less than 10KB but nt sure how to get that to work. WHat am I doing wrong below
lcd \\fil\prod\fsroot
cd /
put -filemask="*.txt; *.trg; */tp/; */aa/" *