Connection failed message

Advertisement

prajsz
Joined:
Posts:
3
Location:
Slovenia

Connection failed message

Hi

I'm new on this forum, but I'm using SCPFTP client for a while...
There was no problems since recently. I'm receiving message "Connection failed".

With connecting to SFTP servers, I do not have any problems.
But with FTP I have specific problem, that I couldn't find a resolution.

When I connect to the server from GUI it works. When I run manualy script it works.
But when I want to automate (with SSIS, or Task Sheduler) it won't work. It constantly returning error message. If I restart the server I run the SCPFTP it works for a day or two, but then just stops working. After restart, automated tasks works again for a while...

= This is my transfer.CMD file:
set isodate=%date:~10,4%%date:~7,2%%date:~4,2%
rem echo %isodate%
"C:\Program Files (x86)\WinSCP\WinSCP.com" /script=C:\tmpScripts\SOA2ADM9800.txt /log="\\v-orion-ftp\FTP_Data\_FTPlogs\SOA2ADM-9800-%isodate%.txt"

= This is the FTP script file:
option batch off
option confirm off
open ftp://user:pass@mobilemd1:21
option transfer ascii
put -delete -nopreservetime \\v-orion-ftp\FTP_Data\Log\Provisioning\FTP\SOA2ADM\9800-SOAadmMediation-??????????????.
mv *. *.TXT
close
exit

= LOG
. 2013-11-23 11:50:30.187 --------------------------------------------------------------------------
. 2013-11-23 11:50:30.189 WinSCP Version 5.1.7 (Build 3446) (OS 6.1.7601 Service Pack 1)
. 2013-11-23 11:50:30.191 Configuration: C:\Program Files (x86)\WinSCP\WinSCP.ini
. 2013-11-23 11:50:30.192 Local account: TS\prajsz
. 2013-11-23 11:50:30.193 Working directory: C:\Windows\system32
. 2013-11-23 11:50:30.194 Process ID: 9244
. 2013-11-23 11:50:30.196 Command-line: "C:\Program Files (x86)\WinSCP\WinSCP.exe" /console=517 /consoleinstance=_11208_224 "/script=C:\tmpScripts\SOA2ADM9800.txt" "/log=\\v-orion-ftp\FTP_Data\_FTPlogs\SOA2ADM-9800-20131123.txt"
. 2013-11-23 11:50:30.198 Time zone: Current: GMT+1, Standard: GMT+1, DST: GMT+2, DST Start: 31.3.2013, DST End: 27.10.2013
. 2013-11-23 11:50:30.198 Login time: 23. november 2013 11:50:30
. 2013-11-23 11:50:30.199 --------------------------------------------------------------------------
. 2013-11-23 11:50:30.201 Session name: soa@mobilemd1 (Ad-Hoc session)
. 2013-11-23 11:50:30.201 Host name: mobilemd1 (Port: 21)
. 2013-11-23 11:50:30.202 User name: soa (Password: Yes, Key file: No)
. 2013-11-23 11:50:30.204 Tunnel: No
. 2013-11-23 11:50:30.204 Transfer Protocol: FTP
. 2013-11-23 11:50:30.205 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2013-11-23 11:50:30.207 Proxy: none
. 2013-11-23 11:50:30.208 FTP: FTPS: None; Passive: Yes [Force IP: A]; List all: A
. 2013-11-23 11:50:30.210 Local directory: default, Remote directory: home, Update: Yes, Cache: Yes
. 2013-11-23 11:50:30.210 Cache directory changes: Yes, Permanent: Yes
. 2013-11-23 11:50:30.212 DST mode: 1; Timezone offset: 0h 0m
. 2013-11-23 11:50:30.212 --------------------------------------------------------------------------
. 2013-11-23 11:50:30.214 Connection failed.

I have admin rights on this server and on the server (network location) I get files from also.

Do you have any suggestions?

Version od SW, I'm using: 5.1.7 (build 3446)

Thank you in advance

BR
iga

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Connection failed message

How frequently are you running the task?
_________________
Martin Prikryl

Reply with quote

prajsz
Joined:
Posts:
3
Location:
Slovenia

Re: Connection failed message

martin wrote:

How frequently are you running the task?

Once per minute per target server: 4 times FTP connection, 2 times SFTP connection.
Always sequentially from SQL job.

BR
iga

Reply with quote

prajsz
Joined:
Posts:
3
Location:
Slovenia

Re: Connection failed message

martin wrote:

While the symptoms are somewhat different, it's possible that you are a victim of this bug:
https://winscp.net/tracker/show_bug.cgi?id=996

Try to upgrade to the latest beta version.

Thanks for the help...

However, over the weekend I moved scripts for FTP conn only to another server.
I'm going to wait and see if the problem repeats (now I sheduled FTP transfers once per 5 minute). If it does, I will install the newest beta (5.2.6) and then hope for the best. :)

Thank you again

BR
iga

Reply with quote

Advertisement

You can post new topics in this forum