Topic "Problem with SFTP and UTF8 encoding"

Author Message
JoeMue

Guest


Hello!

Support for utf8-encoding when using SFTP does not work. Although I set utf8-encoding for file names in the environment to yes, file names and directories are displayed wrong. German umlaute (, , ) are displayed in their isolatin representation of the ut8 encoded string.
Example: "Büro" instead of "Bro"

This does not seem to be a server problem. All other clients I tried (and I tried them all... FileZilla, CoreFTP, SmartFTP, WS_FTP, ...) display these names correctly.

Jochen
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
DonD
[View user's profile]

Joined: 2016-02-18
Posts: 3
Location: Germany, Cologne
Hello @all!

I'm new in here and I saw this topic during my attempt to solve the same Problem which is described in here.
I would be glad if someone could help me by giving me a solution.

Thank's a lot.

Greets DonD
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
You have to give us a way more information.

What protocol? What UTF-8 setting do you use? Did you try the other options?
Did you read https://winscp.net/eng/docs/faq_utf8 ?
DonD
[View user's profile]

Joined: 2016-02-18
Posts: 3
Location: Germany, Cologne
Hello Martin!

I'm using WinSCP 5.5.0,

Settings:
SFTP, if rejected, use FTP;
Language: German;
Default Encoding: UTF-8;

I've allready read the other options, but I didn't find any further Settings.

Thanks for your help.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
There's no "SFTP, if rejected, use FTP" mode. So what protocol do you use, SFTP or FTP?
What value do you use for UTF-8 encoding for filenames?
DonD
[View user's profile]

Joined: 2016-02-18
Posts: 3
Location: Germany, Cologne
Sorry, i'm running late, but it's very busy in here...

I use SFTP and UTF-8.
But to give you some more information i've attached some files.
Unbenannt2.JPG (56.33 KB) Private file

Description: Encoding

Unbenannt.JPG (41.52 KB) Private file

Description: Session and Connection

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
It says "knock", not "use".

"UTF-8 Encoding for Filenames" option is here:
https://winscp.net/eng/docs/ui_login_environment#utf

The option you are showing is for the internal editor.
So where do you get the problem with UTF-8? In the file names (what this topic is about) or in the internal editor?
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License