Topic "Help using multiple masks in my script"

Author Message
xmrkite
[View user's profile]

Joined: 2012-08-09
Posts: 5
Hello, I just can't get masks to work from my script.

Here is my options file below:

option batch abort
option confirm off
open test
synchronize remote -filemask="|*.bak; *.zip; */abc/" "C:\Documents and Settings\test\Desktop\test" "/" -delete
exit


So i want to transfer everything except the .bak, .zip files and skip the abc folder.
What am I doing wrong? This won't even complete with that in there. I am using winscp 4.x
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
There's no -filemask switch in 4.x. Please upgrade to 5.0.8 RC or use "option exclude <mask>" with 4.x
https://winscp.net/eng/docs/scriptcommand_get
https://winscp.net/eng/docs/scriptcommand_option
_________________
Martin Prikryl
xmrkite
[View user's profile]

Joined: 2012-08-09
Posts: 5
OK, I got it

Here is what worked (since I could not find this anywhere online)
option exclude *.bak;*.sql;test1*

This takes out all .bak and .sql files from the backup as well as the test1 folder.

-Thanks
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License