Command 'ls -la ' failed with return code 2

Advertisement

braykov
Joined:
Posts:
89

Command 'ls -la ' failed with return code 2

Steps to reproduce:
1) On the remote panel, go to a folder with some files where you have full access
2) Have a terminal opened and "cd" in the parent folder
3) In the terminal delete the child folder and create it again (may also "touch" some files inside)
4) In WinSCP CTRL+R to refresh the remote panel
Result:
Command 'ls -la '
failed with return code 2 and error message
. not found.
5) Click OK
Result: Nothing gets refreshed
6) repeat from 4)
Result: Nothing ever gets refreshed, but the folder is there
7) In WinSCP navigate up the path, then down
Result: It does refresh without error

Environment:
Windows 7, 32-bit; WinSCP 5.1.4; Server: AIX 6.1

WinSCP Preferences:
Environment->Panels->Remote:

    [x] Show inaccessible directories
    [x] Automatically refresh directory after operation
    [ ] Refresh remote panel every

Session option for "Try to get full timestamp" is disabled.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Command 'ls -la ' failed with return code 2

What protocol? SCP?
_________________
Martin Prikryl

Reply with quote

braykov
Joined:
Posts:
89

Yes, it is SCP.

I just want to add that this appears to lead to another very nasty defect.
If I have a remote file open for editing locally, and I save it while this remote panel is showing a folder that was deleted and re-created, then transportation of the saved file back to the server fails.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Please attach a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

Reply with quote

braykov
Joined:
Posts:
89

OK, I just sent 3 logs, for each type of logging.
I hope it helps.
When I manage to reproduce also the saving problem, I will send again.

NOTE: I tried SFTP - and no such problem.

Last edited by braykov on 2013-03-29 18:15; edited 1 time in total

Reply with quote

braykov
Joined:
Posts:
89

Great, I reproduced it.
Log sent with some more info in the mail.
I hope you are able to resolve this as it is very tricky.

Reply with quote

Advertisement

You can post new topics in this forum