TL-WR740N and pam_unix(sshd:session): session closed for use

Advertisement

poiuty
Joined:
Posts:
4
Location:
Moscow

TL-WR740N and pam_unix(sshd:session): session closed for use

After I started to use the router TL-WR740N
Have disconnect when use SFTP.
In logs

Jan  2 19:11:02 sun sshd[722633]: Accepted password for root from x.x.x.x port 55889 ssh2
Jan  2 19:11:02 sun sshd[722633]: pam_unix(sshd:session): session opened for user root by (uid=0)
Jan  2 19:11:02 sun sshd[722633]: subsystem request for sftp
Jan  2 19:50:03 sun sshd[718357]: pam_unix(sshd:session): session closed for user root    

At the same time, in putty -> no disconnect.

Reply with quote

Advertisement

poiuty
Joined:
Posts:
4
Location:
Moscow

get winscp log
Initiating key re-exchange (timeout)
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Initialised AES-256 SDCTR client->server encryption
Initialised HMAC-SHA-256 client->server MAC algorithm
Initialised AES-256 SDCTR server->client encryption
Initialised HMAC-SHA-256 server->client MAC algorithm    

Reply with quote

poiuty
Joined:
Posts:
4
Location:
Moscow

winscp log

Initiating key re-exchange (timeout)
Network error: Software caused connection abort
(ESshFatal) Network error: Software caused connection abort
Looking up host "x.x.x.x"
Connecting to x.x.x.x port 22
Server version: SSH-2.0-OpenSSH_5.3
Using SSH protocol version 2
We claim version: SSH-2.0-WinSCP_release_5.5
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Verifying host key 
Host key matches cached key
Host key fingerprint is:
ssh-rsa 2048 
Initialised AES-256 SDCTR client->server encryption
Initialised HMAC-SHA-256 client->server MAC algorithm
Initialised AES-256 SDCTR server->client encryption
Initialised HMAC-SHA-256 server->client MAC algorithm    

server log
Jan  4 09:54:19 sun sshd[212908]: Accepted password for root from x.x.x.x port 49397 ssh2
Jan  4 09:54:19 sun sshd[212908]: pam_unix(sshd:session): session opened for user root by (uid=0)
Jan  4 09:54:19 sun sshd[212908]: subsystem request for sftp
Jan  4 10:27:50 sun sshd[212908]: pam_unix(sshd:session): session closed for user root
Jan  4 10:54:26 sun sshd[281019]: Accepted password for root from x.x.x.x port 50660 ssh2
Jan  4 10:54:26 sun sshd[281019]: pam_unix(sshd:session): session opened for user root by (uid=0)
Jan  4 10:54:27 sun sshd[281019]: subsystem request for sftp    

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: TL-WR740N and pam_unix(sshd:session): session closed for use

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl

Reply with quote

poiuty
Joined:
Posts:
4
Location:
Moscow

I turned on keepalives and the problem disappeared
<invalid hyperlink removed by admin>

But in putty
<invalid hyperlink removed by admin>

I'll try to get the full log[/img]

Reply with quote

Advertisement

You can post new topics in this forum