No prompt for username on saved sessions w/o username

Advertisement

slimbim
Guest

No prompt for username on saved sessions w/o username

WinSCP 5.5.1 (Build 3970).

Have saved sessions, with no username defined, but when connecting, it does not prompt me for username, but only password.

-- If I use blank New Site session and type in host name, with blank user name, it prompts for username as expected.
-- If I use saved session with Host name and username filled in, it displays Using username "username" and prompts for just password as expected.
-- If I use saved session with just Host name filled in but no username, it just prompts for password, without any mention of username (i.e. no Using username "username") for me to know what it is trying to use for username.

Anyone experiencing this?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,033
Location:
Prague, Czechia

Re: No prompt for username on saved sessions w/o username

I wan not able to reproduce this.

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,033
Location:
Prague, Czechia

Thanks for the log. You are not prompted for (EDIT) username, because you have selected GSSAPI authentication. In that case WinSCP leaves username deduction to GSSAPI. Turn off GSSAPI, if you are not actually using it (it's turned off by default).

Reply with quote

Advertisement

You can post new topics in this forum