Topic "The uploaded file has a wrong timestanp"

Author Message
vani.rengan@...

Guest


When I upload a file to WinSCP, the time is right but the year is different. It is 1 year past and displays 2013 instead of 2014. I came across various solutions provided in WinSCP forum and unchecked the "Preserve Timestamp" in Environment tab and it does not work still. The time gets updated but not the year. Any solution on this at the earliest would be much appreciated.

FYI: I thought I had an older version of WinSCP and downloaded a new WinSCP version to see if the issue gets fixed but unfortunately No.The Newest version which I use is 5.5.1
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25025
Location: Prague, Czechia
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
Vani

Guest


Hi Prilky,

Thanks for your email. I hae attached the logs. Can you please have a view.
By the way, I am not able to find your email address. Cna you please post it here.

Thank you so much.
WinSCP.log (8.81 KB) [Download]

Description: Log file of WinSCP

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25025
Location: Prague, Czechia
Thanks for the log.
It's for the test with Preserve timestamp turned off, right?
In this case it's the server who set's the time (should set it to current time). The timestamp in directory listing returned by server after upload is interpreted by WinSCP as 2013-03-20T10:17:00.000Z. To be 100% sure, it's a server-side bug, I'd have to see Debug 1-level log.
See: https://winscp.net/eng/docs/ui_pref_logging

Can you also post a Debug 2-level log for test with Preserve timestamp turned on?
vani.rengan@...

Guest


Simply Awesome..

The issue fixed after when "Preserve timestamp" was turned on.

Thanks a lot!! Excellent support...
Akash

Guest


I have the latest version of WinScp, but the preserve timestamp is grayed out. how can i enable the option. please help. Many Thanks
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25025
Location: Prague, Czechia
Akash wrote:
I have the latest version of WinScp, but the preserve timestamp is grayed out. how can i enable the option. please help. Many Thanks

See documentation to find why the option may be disabled:
https://winscp.net/eng/docs/ui_transfer_custom#common_options
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License