Topic "SFTP protocol violation: Invalid response message type (0)"

Author Message
myelin

Guest


Hello,

I have a problem with making new folder, or copy folder in SFTP connection. I've clean all data, sessions, reinstall winscp but problem still occurs. I've tried filezilla and there it is no problem. Connection to server going normally, but after trying to make a new folder anywhere, or copy folder this is the error: SFTP protocol violation: "Invalid response message type (0). Error creating folder 'folder' ". Copy files and deleting or updating goes normally.

WinSCP 5.7 I'm using long time but today after make som changes in session info there is this error. As I mentioned I've tried to clean all and connect but still nothing.

I login in saved session. After that I press F7 key and try to make new directory. After that winscp show me error message.
I'm using GUI - Commander, Windows 8.1 64 bit, WinScp 5.7 last build and log file is attached.
error.zip (3.77 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24993
Location: Prague, Czechia
Thanks for your report.
It looks like a bug in ProFTPD/mod_sftp server.

I have reported it:
http://bugs.proftpd.org/show_bug.cgi?id=4160

As a workaround, force SFTP version 5:
https://winscp.net/eng/docs/ui_login_sftp
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License