Topic "sftp broken by recent updates to debian testing?"

Author Message
pjlbyrne
[View user's profile]
Donor
Joined: 2015-03-23
Posts: 8
Location: United Kingdom
Hi,

I am using latest winscp (5.7). I use it to copy files up to my debian server. This is running debian testing (jessie), and after I upgraded with apt-get at the weekend I started getting transfer errors.

I am guessing that this update to libssl2 is the culprit:
http://metadata.ftp-master.debian.org/changelogs/main/libs/libssh2/libssh2_1.4.3-4.1_changelog

I get 'Host is not communicating for more than 15 seconds. Still waiting...'.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
I assume your Debian uses OpenSSH server for SSH/SFTP, right? I do not think libssh2 is used by OpenSSH.
pjlbyrne
[View user's profile]
Donor
Joined: 2015-03-23
Posts: 8
Location: United Kingdom
prikryl wrote:
I assume your Debian uses OpenSSH server for SSH/SFTP, right? I do not think libssh2 is used by OpenSSH.


Oh well. It was the only recent update in /var/log/dpkg.log with 'ssh' in it:

me@home ~ $ grep -i ssh /var/log/dpkg.log
2015-03-10 09:27:50 upgrade task-ssh-server:all 3.29 3.30
2015-03-10 09:27:50 status half-configured task-ssh-server:all 3.29
2015-03-10 09:27:50 status unpacked task-ssh-server:all 3.29
2015-03-10 09:27:50 status half-installed task-ssh-server:all 3.29
2015-03-10 09:27:50 status half-installed task-ssh-server:all 3.29
2015-03-10 09:27:50 status unpacked task-ssh-server:all 3.30
2015-03-10 09:27:50 status unpacked task-ssh-server:all 3.30
2015-03-10 09:28:44 configure task-ssh-server:all 3.30 <none>
2015-03-10 09:28:44 status unpacked task-ssh-server:all 3.30
2015-03-10 09:28:44 status half-configured task-ssh-server:all 3.30
2015-03-10 09:28:44 status installed task-ssh-server:all 3.30
2015-03-22 12:32:43 upgrade libssh2-1:amd64 1.4.3-4 1.4.3-4.1
2015-03-22 12:32:43 status half-configured libssh2-1:amd64 1.4.3-4
2015-03-22 12:32:43 status unpacked libssh2-1:amd64 1.4.3-4
2015-03-22 12:32:43 status half-installed libssh2-1:amd64 1.4.3-4
2015-03-22 12:32:43 status half-installed libssh2-1:amd64 1.4.3-4
2015-03-22 12:32:43 status unpacked libssh2-1:amd64 1.4.3-4.1
2015-03-22 12:32:43 status unpacked libssh2-1:amd64 1.4.3-4.1
2015-03-22 12:32:48 configure libssh2-1:amd64 1.4.3-4.1 <none>
2015-03-22 12:32:48 status unpacked libssh2-1:amd64 1.4.3-4.1
2015-03-22 12:32:48 status half-configured libssh2-1:amd64 1.4.3-4.1
2015-03-22 12:32:48 status installed libssh2-1:amd64 1.4.3-4.1
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Please attach a full log file on Debug 2 logging level showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. If you do not want to post the log publicly, you can mark the attachment as private.
pjlbyrne
[View user's profile]
Donor
Joined: 2015-03-23
Posts: 8
Location: United Kingdom
upgraded to 5.7.1 - log attached
anselm@nelly.zip (166.55 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Thanks for the log. But I haven't found any clue there. It looks like the server stops communicating.
Btw, didn't you upgrade WinSCP about the same time the problem was introduced?
pjlbyrne
[View user's profile]
Donor
Joined: 2015-03-23
Posts: 8
Location: United Kingdom
> Btw, didn't you upgrade WinSCP about the same time
> the problem was introduced?

You know, I think I did. I will try reverting when I have a moment (and am at home).

[of course, I am sure the excellent winscp software would not be at fault!]
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
It could be the same problem as here:
https://winscp.net/forum/viewtopic.php?t=15035

Please test 5.6.2 and 5.6.3, as per:
https://winscp.net/forum/viewtopic.php?p=55603#55603
pjlbyrne
[View user's profile]
Donor
Joined: 2015-03-23
Posts: 8
Location: United Kingdom
Thanks, yes you were right. 5.6.1 is okay, 5.6.3 fails.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Thanks.
I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
This bug has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1306
pjlbyrne
[View user's profile]
Donor
Joined: 2015-03-23
Posts: 8
Location: United Kingdom
Nice Mr Prikryl has fixed my problem, and I have donated some money to him to show my appreciation. I am bragging about it on this forum to encourage others Very Happy

Support Open Source Software!
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Thanks!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License