Can't change server time zone settings

Advertisement

countytime
Joined:
Posts:
9

Can't change server time zone settings

My server is set to GMT, which is 4 hours ahead. I'd like to adjust that so I can use WinSCP's synchronize features, but the option in Advanced Site Settings is greyed out, like so:



How do I change that? (Or if there's some other change I can make so that synchronization works, that's fine too.)

Last edited by countytime on 2015-05-08 23:51; edited 1 time in total

Reply with quote

Advertisement

countytime
Joined:
Posts:
9

Re: Can't change server DST settings

martin wrote:

So are you asking about DST (as per subject) or time-zone offset (as per text)?

In either case, see documentation:
https://winscp.net/eng/docs/ui_login_environment
It documents when the options are available.

Fixed, thanks.

What I actually had to do was go into the advanced site settings, and

1. Set MSLD to "off"
2. Uncheck "detect automatically" **but leave the difference at zero**. It was the detecting automatically that did it; simply turning that off fixed it. (When I manually subtracted 4 hours, it came out 4 hours early.)

Reply with quote

countytime
Joined:
Posts:
9

Or not fixed =x What happens is it works on the very first change, uploads the new file, but when it appears on the server the timestamp is blank. Not just wrong, but blank. Then it stops uploading automatically. If I manually click an upload through, the timestamp reappears.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Can't change server DST settings

Can you attach a log file showing directory listing with default settings (MLSD on/auto)?
Mention what timestamp WinSCP shows for a certain file and what timestamp do you expect and why.

Reply with quote

Advertisement

You can post new topics in this forum