Topic "FTP small file transfers result in 0 byte files"

Author Message
[View user's profile]

Joined: 2015-06-19
Posts: 1

I am using the current version of Winscp, 5.7.3 and transfering files using FTP with TLS/SSL Explicit encryption. Transferring smaller files, many of them just under 800 bytes and finding most arrive as 0 byte files on the server. This happens both with the GUI and the .net component (ultimately would love to send them using .net but found it happens on GUI as well so if that works maybe both will), happens whether I am trying transfer as text or binary.

Appears this was a bug on some earlier Winscp versions, so I tried to upgrade first to 5.7.3 but finding the same behavior. Tried the transfer in another product Filezilla using FTP and did not encounter the 0 byte issue, though I could find no significant difference in the settings.

If you have any info or recommendations let me know. I really appreciate any help.
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27059
Location: Prague, Czechia
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License