Unable to delete local directories

Advertisement

voidpointer
Joined:
Posts:
6

Unable to delete local directories

When I delete a directory in the Local pane, I get an error trying to delete the file.

Logs show:


* 2015-08-11 17:34:16.570 (EOS3xtException) Error deleting file 'C:\System\content\asdf'.

(I had to replace the E above with a 3 in the exception name because forum spam filters thought I was putting in a dirty word lol)

I'm on Windows 8.1 x64. I have UAC disabled, but regardless of that fact I attempted running WinSCP as administrator and it made no difference.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: Unable to delete local directories

Do you have the problem with any file, or just this one?
I assume there must be more details in the error message.

Reply with quote

Guest

Re: Unable to delete local directories

martin wrote:

Do you have the problem with any file, or just this one?
I assume there must be more details in the error message.

This only happens with directories. In this case, `asdf` is an empty directory. For files, it deletes just fine.

Note in the error it says it can't delete FILE, but it's a directory. It sounds like maybe WinSCP is trying to delete a directory as a file (just based on wording).

And as far as logs go, I enabled detail logging but that's literally all that is in the logs of interest. Everything else has nothing to do with the error. Unless you know of some more detailed logs somewhere.

Reply with quote

Advertisement

voidpointer
Joined:
Posts:
6

OHHHHHHHHHHHHHHHHHHHH I know what it is now!! I can't believe I forgot.

The directory I'm deleting is contained inside of a symlink on windows, which I created with "mklink /D".

Does WinSCP not support deleting directories contained inside of symlink dirs? When I delete directories not inside a symlink dir, it deletes them just fine.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

I cannot reproduce the problem. How do you delete the folder in WinSCP? Do you have deleting local files to a recycle bin enabled or disabled?

Reply with quote

voidpointer
Joined:
Posts:
6

martin wrote:

I cannot reproduce the problem. How do you delete the folder in WinSCP? Do you have deleting local files to a recycle bin enabled or disabled?
Whatever the default setting is. I haven't changed any settings.

Note I'm deleting an empty DIRECTORY, that is located within an application link 2 levels deep. Example:

E:\RealData (real directory, containing subdirectories and files)
E:\FakeData\_stuff (link to ==> E:\RealData)
C:\RealData (link to ==> E:\FakeData\_stuff)

All directory links were created via "mklink /D" on Windows 8.

Try to reproduce this directory setup (specifically across drives) and see if you can repro the issue. Thanks for helping out.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum