Unable to disable preserver timestamps using command

Advertisement

Dixiaosin
Guest

Unable to disable preserver timestamps using command

hi, I try to using Winscp GUI and disable the preserver timestamps, it sucessfully let me to drop the file from local to remote without getting the error message
"upload of file was successful but error occurred while setting the permissions and/or timestamp"

But when i want to write into script for automation, i cant upload my file from local to remote.
I getting this error message:

Permission denied.
Error code: 3
Error message from server: Permission Denied!

My script is:
put -delete -nopreservetime -resumesupport=off -nopermissions D:\Output\ForPrestige\* /

anything went wrong of the script?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Re: Unable to disable preserver timestamps using command

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Dixiaosin
Guest

Re: Unable to disable preserver timestamps using command

martin wrote:

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Here you go.. i had attached the log file for your reference

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Re: Unable to disable preserver timestamps using command

You simply do not have write permissions to the root folder (/). What is quote common, unless your account is chrooted.

Make sure you use a correct path.

Show us a log from GUI for a successful transfer.

Reply with quote

Guest

Re: Unable to disable preserver timestamps using command

martin wrote:

You simply do not have write permissions to the root folder (/). What is quote common, unless your account is chrooted.

Make sure you use a correct path.

Show us a log from GUI for a successful transfer.

Hi,

I found that in GUI, it said that some specific path into that folder. I just addin behind the / and my files are successfully transfer.
Thanks so much for your help.. ^^

Reply with quote

Advertisement

You can post new topics in this forum