Fatal error while disposing the sFTP queue

Advertisement

ravikumar
Joined:
Posts:
2

Fatal error while disposing the sFTP queue

Hi,

I am using WinSCP 5.7 version. Received the following error message in the winSCP logs and the WinSCP re-transmitted the file(we have automatic reconnect options enabled).
To add bit more information,
- In the first attempt the file was successfully received by the destination company,
- But not sure why these problem occurred even though the other company received the complete file.
- WinSCP retransmitted the same file again. This time also the destination company received the complete file.
- The WinSCP logs were clear on the second attempt.
Can someone help to identify the possible situation when these errors can occur.

-----------------------------
Server unexpectedly closed network connection
Fatal error while disposing the SFTP queue.
Connection was lost, asking what to do.
Asking user:
Server unexpectedly closed network connection ()
Script: Server unexpectedly closed network connection
Script: Searching for host..
.
.
.
.
.
-----------------------------

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,096
Location:
Prague, Czechia

Re: Fatal error while disposing the sFTP queue

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

ravikumar
Joined:
Posts:
2

Attached the full log of error

Please see the attached log.

Could you please help us.

Please let us know if you required more information.
  • sFTP_Full_Log.log (14.6 KB, Private file)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,096
Location:
Prague, Czechia

Re: Attached the full log of error

Thanks for the log.

It indeed loos like the server closes the connection once the upload finishes.

After a reconnect, the file probably does not exist anymore on the server. So WinSCP uploads it again.

It looks like a bug on the server-side.

Reply with quote

Guest

Thanks for the reply.

Could you please kindly give us any suggestion to prevent this behavior.

Any changes at server side or any changes in WinSCP settings which can prevent this?

Thank You.

Reply with quote

Advertisement

Guest

Hi,

Could you also please let us know which server you thing has the bug in it.
Is it
Server A which has the WinSCP client? or
Server B which has the sFTP server installed or
WinSCP application bug?

Please see the diagram for more understanding of the example.

Thank You,
Viral

Diagram.jpg

Diagram.jpg

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,096
Location:
Prague, Czechia

Of course the "Server B which has the sFTP server installed".

I do not know anything about the server, so I cannot help you further, sorry.

Reply with quote

Guest

Hi,

Thank You very much for helping so far on this.

Could you please help on this.

WinSCP 5.7.4 has the option "Automatically reconnect session, if breaks during transfer". We have set this to "Reconnect after" 5 seconds.
If we disable this option then WinSCP would not reconnect automatically and throw us the error rather than reconnecting itself and sending the file again. Then we can fix the problem and do the file transfer again manually.
Our files are less than 100 kb.

Could you please kindly let us know
1. Is my understanding correct?
2. Will this change can bring other problems?
3. Is it a wise option to disable this reconnect if it breaks during transfer?

Thanks in Advance,
Viral

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,096
Location:
Prague, Czechia

That's correct. While it's reasonable to have the option on in general, for your specific case, it makes sense to turn it off.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum