How to configure WinSCP for Webdav with Two Factor Authentication

Advertisement

integration77
Joined:
Posts:
4

How to configure WinSCP for Webdav with Two Factor Authentication

Hi,
I'm trying to connect to a website using WebDav and the Two Factor Authentication and it fails.
As recommended, I'm using the 5.8.2 beta version of WinSCP.
The site is DemandWare (URL beginning with cert.environnement.etc...). We had to create/export a certificate containing the .crt provided by DemandWare + our client information into pkcs12 format.
So it uses WebDav protocol, port 443, and I included the .p12 certificate into "Client certificate file" under Advanced.

BUT... it tries to connect indefinitely...

Do you have any ideas about it ?

Thanks for your help !

Reply with quote

Advertisement

integration77
Joined:
Posts:
4

Re : Re: How to configure WinSCP for Webdav with Two Factor Authentication

Hi,
Thanks for your answer.
I've downloaded the provided 5.8.3 portable version
After few times trying to connect, I get this error message :
"Could not connect to server: Socket error 10057
Connection failed."
Maybe this time it's a configuration issue from my side ?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Re : Re: How to configure WinSCP for Webdav with Two Factor Authentication

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

integration77
Joined:
Posts:
4

Hi,

I've enabled logging Debug2 (I think it's the highest level).
Here's the attachment as private file.

Thanks
  • cert.staging.web.picard.demandware.net.log (3.23 KB, Private file)

Reply with quote

integration77
Joined:
Posts:
4

Hello,

I found the cause of the issue (and that's my mistake) : I had to declare a proxy server for any connexions + specify a remote directory on the advanced settings.
When fields filled, I could connect properly and it works fine with the 5.8.2 beta version.

Sorry for the inconvenience and many thanks for your support !

Regards,

Florent

Reply with quote

Advertisement

You can post new topics in this forum