Topic "Disabling temporary file name during transfert"

Author Message
Patchi

Guest


Hello,

I put file on a SFTP server successfully with the user interface.
But, I run it as a script, the files are first copied with a temporary extension on the SFTP server, and then I suppose WINSCP will rename them.

The point is that I won't be allowed to rename file on the server.
How can I disable the temporary file name transfert mode in a batch mode ?

I read the manual, FAQ and search in the forum.


Is there anyoption for that ?

Patchi
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27059
Location: Prague, Czechia
Use the -resumesupport switch: put -resumesupport=off ...

https://winscp.net/eng/docs/ui_pref_resume#temporary
https://winscp.net/eng/docs/scriptcommand_put#resumesupport
Patchi

Guest


Thanks,

I will try this option and hope will solve the following error message I get.

winscp> put ARTMAS_24399482_1.txt
ARTMAS_24399482_1.txt | 463 KiB | 2673,2 KiB/s | binary | 100%
Cannot close remote file 'ARTMAS_24399482_1.txt'.
General failure (server should provide error description).
Error code: 4
Error message from server: EBIBrokerSshFile.NullDocument
(A)bort, (R)etry, (S)kip, Ski(p) all: Skip
Advertisements

You can post new topics in this forum

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License