Not preserving timestamp

Advertisement

Saul1
Joined:
Posts:
7
Location:
Germany

Not preserving timestamp

Hello,
I`m using 5.13 build 8172 GUI mode, W10 64bit and W7 32bit.
When I transfer a file, I noticed that the timestamp of the transfered file was set to the computer timestamp instead of the timestamp of the source file.
This happens with SFTP and WebDav protocol.
It looks like the preserve timestamp setting is ignored.
Is that a bug or wrong adjustment?

Thanks
Wolfgang

Reply with quote E-mail

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Not preserving timestamp

Most WebDAV servers indeed do not support preserving timestamps of uploaded files.
https://winscp.net/eng/docs/ui_transfer_custom#common

But it should work with SFTP. If it does not, please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Saul1
Joined:
Posts:
7
Location:
Germany

Hello,
attached find the log
  • Cloud-EDFC.log (27.84 KB, Private file)
  • V_Privat_Verschicken_Unbenannt.pdf (159.33 KB, Private file)

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

SFTP log file please.
You have posted a WebDAV log. I've already explained above that you cannot expect this to work with WebDAV.

Reply with quote

Advertisement

You can post new topics in this forum