Amazon S3 Region

Advertisement

Guest

Amazon S3 Region

In a nutshell: we need the ability to set the default connecting region as part of the configuration for a S3 Login Session.

We are connecting to an S3 clone service (like dreamhost's S3 clone). Our clone service has different region names from the standard AWS s3. On the WinSCP, S3 login page, when we click login, we receive the error: "The autorization header is malformed; the region 'us-east-1' is wrong; expecting '<our providers region name>'.

Reply with quote

Advertisement

Guest

Steps to replicate

1) Turn on session logging
2) Connect to the regular AWS S3 service
3) search the session log for the line (near the top of the file): "S3: Default region: us-east-1"

Update WinSCP so we can configure the Default Region variable. Receive donation.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: Amazon S3 Region

Thanks for your post.

Can you send me an email, so I can send you back a development version of WinSCP for testing? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: A3 country code change

gintasr wrote:

Need a possibility to change country code in A3 login.
What is A3? Do you mean S3? What is country code for?

Reply with quote

gintasr
Joined:
Posts:
8
Location:
Lithuania

Re: A3 country code change

martin wrote:

gintasr wrote:

Need a possibility to change country code in A3 login.
What is A3? Do you mean S3? What is country code for?

Sorry, it's a S3. Need to be Default Region [US], in the debuglog- S3: Default region: us-east-1

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: A3 country code change

gintasr wrote:

Sorry, it's a S3. Need to be Default Region [US], in the debuglog- S3: Default region: us-east-1
us-east-1 is the default region.

Reply with quote

gintasr
Joined:
Posts:
8
Location:
Lithuania

Re: A3 country code change

martin wrote:

gintasr wrote:

Sorry, it's a S3. Need to be Default Region [US], in the debuglog- S3: Default region: us-east-1
us-east-1 is the default region.

We need a possibility to change.

Reply with quote E-mail

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: A3 country code change

gintasr wrote:

In our case should be s3.us.amazonaws.com, however, not working in 5.14.1
Are you sure about that? I've never seen such S3 endpoint. Do you have any reference for this?
See https://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region

Anyway, please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

So do you have any reference for that hostname?

Also it does not look like you have changed the hostname to s3.us.amazonaws.com. I see the default s3.amazonaws.com hostname in the log.

Reply with quote

gintasr
Joined:
Posts:
8
Location:
Lithuania

Setting a s3.us.amazonaws.com did not finds server name, because port 443 redirects to sub server.
We currently using CrossFTP and it works well with current settings - see attachement

CrossFTP.jpg

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

gintasr wrote:

Setting a s3.us.amazonaws.com did not finds server name, because port 443 redirects to sub server.
We currently using CrossFTP and it works well with current settings - see attachement
How do you change "country code" in CrossFTP?

Reply with quote

gintasr
Joined:
Posts:
8
Location:
Lithuania

Seems in CrossFTP - default is US.
Could be a problem is the "Secret access key" contains a special ASCII chars - like - "/+_" ?

Reply with quote E-mail

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

US is S3 default. So do you have actually any reason to believe that your problem is about "country code"?

Special characters in the Secret access key should not be problem in WinSCP GUI (can be a problem in scripting).

Though the error message that you are getting indeed suggests that your credentials are wrong.

Are you able to login with WinSCP to S3 anyhow? (e.g. different set of credentials, different bucket, whatever)

Reply with quote

Advertisement

You can post new topics in this forum