Exclude all files, including only a few

Advertisement

liguzaf
Joined:
Posts:
2

Exclude all files, including only a few

I'm using the 'Keep Remote Directory up to Date' feature with a filemask akin to
filename1; filename2

However, it keeps trying to upload all the files in .git. When excluding .git like so,
filename1; filename2 | .git/
it includes all files. I just want winscp to monitor for changes in 3 or 4 files, some in deeper sub directories than others. Can anyone help me do this?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: Exclude all files, including only a few

Your mask looks good.
If you use the same mask with "Synchronization", does it select correct files?
If not, please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

liguzaf
Joined:
Posts:
2

Oops

I believe that WinSCP was working correctly the entire time, and that I was mistaking the changes that WinSCP was detecting for the actual uploads. Although it was noticing changes that did not meet the file mask, I don't think it was uploading them. I assume this is the intended behavior?

Reply with quote

Advertisement

You can post new topics in this forum