Editing a scss file add extra lines in the file

Advertisement

oloccina
Joined:
Posts:
7
Location:
Italia

Editing a scss file add extra lines in the file

Hello,
I tried to edit a scss file both with the internal editor and sublime text 3 editor, in both cases extra lines are being added to the file (1 extra empty line for each line).
The same file opened form edit in filezilla is fine (no extra lines added).
Can you reproduce this on your side and is there a way to solve it?

Thank you

Description: edit with Filezilla

filezilla-edit.png

Description: edit with WinSCP

winscp-edit.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,762
Location:
Prague, Czechia

Re: Editing a scss file add extra lines in the file

Try forcing binary transfer mode (works with external editors only).

Reply with quote

oloccina
Joined:
Posts:
7
Location:
Italia

Re: Editing a scss file add extra lines in the file

martin wrote:

Try forcing binary transfer mode (works with external editors only).
I tried "binary mode" + sublime text 3 as editor
but I still got the extra lines

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,762
Location:
Prague, Czechia

Re: Editing a scss file add extra lines in the file

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,762
Location:
Prague, Czechia

What did you do to force the binary mode?
I can still see that text/ascii mode is being used:

. 2018-08-07 13:17:28.363 Ascii transfer mode selected.

Reply with quote

Advertisement

You can post new topics in this forum