SFTP file name problems with foreign characters

Advertisement

martyg
Joined:
Posts:
1
Location:
Deutschland

SFTP file name problems with foreign characters

When using special characters (e.g. French 'é' or German Umlaute 'ä') in filenames in SFTP mode, then the filename is shown correctly in WinSCP but you cannot access the file (delete, open etc.). You see the file but when try deleting it the following error message is shown (see also attachment):
No such file or directory.
Error code: 2
Error message from server (en-US): No such file

You can easily reproduce the bug when using another SFTP client (e. g. Bitvise) and create a file with name 'André.txt' in an SFTP directory. Then open that directory with WinSCP - as said, the name is correctly shown in WinSCP, but the deletion fails.

Strange is also that if you create a file in WinSCP with the same name 'André.txt' in the SFTP directory, then it is not shown as 'André.txt' but as 'Andr?.txt'. This file is also deletable.

Using WinSCP 5.13.3 with “Commander” interface on Windows 7, as stated with protocol SFTP. Its the same behaviour for all settings regarding 'Login -> Environment -> UTF-8 encoding for filenames' (Auto, On, Off).

Description: Error msg deletion of existing file

Bug_WinSCP_filename.jpg

Reply with quote

Advertisement

jbk
Guest

SFTP file name problems with foreign characters

I have exactly the same problem as Martyk described. No cure with testing UTF-8 settings. Windows 7. WinSCP build 5.13.3. That's a real shame, cause WinSCP ist otherwise a great peace of software and fullfills our requirements 100%. I think it is not a problem with our provider, cause FileZilla works flawless (but we miss the synchronize feature a lot).

screenshot WinSCP.PNG

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: SFTP file name problems with foreign characters

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Thanks. Can you also post a full log file with "UTF-8 encoding for filenames" set to "Off"?

Reply with quote

Advertisement

You can post new topics in this forum