New and updated files only - Not working

Advertisement

patrik
Joined:
Posts:
2

New and updated files only - Not working

The New and updated files only option from the Transfer Setting Dialog is not working. When I upload the same file again(having older timestamp locally than remote) the file is not ignored but instead wrongly uploaded again.

It seems to be due to the timestamp from the remote file cannot be retrieved. Pls check attached picture.

using version 5.13.
not tested any previous version of the tool.
I am working on Windows 10
Transfer protocol is S3

Description: Picture showing missing timestamp for remote file in Overwrite Confirmation popup.

Capture.PNG

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: New and updated files only - Not working

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

patrik
Joined:
Posts:
2

Log-file attached.

Attached is the log file.
The operation logged was one file uploaded. The transfer setting New and Updated only was checked.
The local file timestamp was 2017-04-05, the remote file timestamp was 2017-08-27. The file was upload even if the time was older locally compared to remote.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: Log-file attached.

OK, sorry, I didn't notice that you are using S3 protocol.
With S3 protocol, the "New and updated files only" does not with with uploads:
https://winscp.net/eng/docs/ui_transfer_custom#other

On the transfer dialog you will see a message "All configured transfer settings cannot be used in current context".

Reply with quote

Advertisement

You can post new topics in this forum