Synchronize "Skip all" only working partly for current folder

Advertisement

Waruwaru
Joined:
Posts:
26
Location:
Deutschland

Synchronize "Skip all" only working partly for current folder

I want synchronize remote to local. Winscp 5.13.4 on Windows 10 (1803 Build 17134.254) with SFTP.
A messagebox appear

and I confirm "skip all". But in next folder its happen again. I want synchronize a very very big folder with tons of sub-folders and files and can not confirm thousand times "skip all". So I wish "skip all" really skip all and not only for the current folder. :)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Re: Synchronize "Skip all" only working partly for current folder

Thanks for your report.

This issue has been added to the tracker:
https://winscp.net/tracker/1678

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

Waruwaru
Joined:
Posts:
26
Location:
Deutschland

This issue still exists in version dev 5.14.2. For german umlauts and japanese kanji in file names.

This issue only happen on long time synchronize (in my case 17 hours) with thousand of folders and thousand of files.

When I take a shorter synchronize (40 minutes), its working fine.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Waruwaru wrote:

This issue still exists in version dev 5.14.2. For german umlauts and japanese kanji in file names.
Can you please elaborate on how "german umlauts and japanese kanji" relate to the "skip all" issue?

Reply with quote

Waruwaru
Joined:
Posts:
26
Location:
Deutschland

The error reported here consists of two parts. Maybe I should have made two topics out of it?
1. issue with utf-8 (umlauts, kanjis)
2. skip-button
Because of issue in point 1 the skip-button show up.

- I have utf8 files on server
- Now I start synchronize with winscp and its calculating comparing for many hours
- after comparing and start copy missing files from server to local its show dialog remote file "###.txt" on server is now missing, should skip?
- But "###.txt" never exists, his name is "ÄÜÖ.txt". winscp damaged the utf8 filename in calculated comparing list and not find the correct file.

But this issue exists only on very long time synchronization. Maybe here is a memory leak for very long list of files?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Waruwaru wrote:

- But "###.txt" never exists, his name is "ÄÜÖ.txt". winscp damaged the utf8 filename in calculated comparing list and not find the correct file.
I got lost in all the issues you have reported.
I've found this post that is about UTF-8:
https://winscp.net/forum/viewtopic.php?t=26728#86680
Did we resolve that?

Reply with quote

Advertisement

You can post new topics in this forum